Please note that User Registration has been temporarily disabled due to a recent increase in automated registrations. If anyone needs an account, please request one here: RequestAccount. Thanks for your patience!--Wmat (talk)
Please email User:Wmat if you experience any issues with the Request Account form.

FR:RPi Debian Python3

From eLinux.org
Jump to: navigation, search


Installation de Python 3.2.3 sur Debian Squeeze

Ce guide est destiné à des développeurs, bien qu'il puisse être utilisé par des débutants si c'est ce qu'ils souhaitent devenir. Il est présenté car il s'avère que la dernière version de Python (3.2) n'est pas disponible dans Debian Squeeze. D'autres distributions Linux pour RPi pourront l'intégrer par défaut à l'avenir. Notez que Raspbian contient déjà Python 3.

Pour installer la dernière version de Python (3.2.3) sur Debian :

# installation des dépendances
sudo apt-get install zlib1g-dev
sudo apt-get install libncurses-dev
sudo apt-get install libbz2-dev
sudo apt-get install libreadline-dev
sudo apt-get install sqlite3 libsqlite3-dev
sudo apt-get install libssl-dev
sudo apt-get install libgdbm-dev
sudo apt-get install tk-dev

wget http://www.python.org/ftp/python/3.2.3/Python-3.2.3.tar.bz2
tar xvfj Python-3.2.3.tar.bz2 
cd Python-3.2.3

./configure
# (La commande 'configure' prend environ 5 minutes)

make
# (La commande 'make' prend environ 46 minutes si vous n'êtes pas sous X)

sudo make install
# (La commande 'make install' prend environ 5 minutes)

cd ~

Raccourci IDLE dans le menu LXDE

Pour ajouter l'icône d'idle dans le menu programmation de LXDE :

sudo mkdir /usr/local/share/applications
sudo nano /usr/local/share/applications/idle.desktop

Entrez le texte suivant dans le fichier :

[Desktop Entry]
Encoding=UTF-8
Exec=idle3 %F
Type=Application
Terminal=false
Name=IDLE
GenericName=IDLE
StartupNotify=false
Categories=Development;IDE;

Module Distribute

Pour installer la plupart des autres modules Python, vous devrez sans doute installer le module 'distribute'. Il remplace 'setuptools' qui est maintenant obsolète :

wget http://pypi.python.org/packages/source/d/distribute/distribute-0.6.26.tar.gz
tar xvfz distribute-0.6.26.tar.gz
cd distribute-0.6.26
sudo python3 setup.py install
cd ~

Module Numpy

Il nécessite énormément de ressources systèmes (mémoire) pour compiler. Lancez-le sans rien faire tourner d'autre - ne le lancez pas sous X ! Vous aurez besoin d'activer le fichier d'échange (swap).

N.B. La compilation prend environ 1h40

wget http://pypi.python.org/packages/source/n/numpy/numpy-1.6.1.tar.gz
tar xvfz numpy-1.6.1.tar.gz
cd numpy-1.6.1
python3 setup.py build
sudo python3 setup.py install
cd ~

Module PyGame

La dernière version (stable) de PyGame n'est pas supportée par Python 3.2 si bien qu'il faut employer le code source de développement. Assurez-vous d'avoir installé le module numpy au préalable. Remarquez que le son ne fonctionne pas pour l'instant - Je mettrai les instructions de ce guide à jour lorsque cela sera corrigé.

(La compilation prend environ 15 minutes).

# récupère le code source de pygame
sudo apt-get install mercurial
hg clone https://bitbucket.org/pygame/pygame
cd pygame

# installation des dépendances
sudo apt-get install libsdl-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev 
sudo apt-get install libsmpeg-dev libportmidi-dev libavformat-dev libswscale-dev

# compilation et installation de pygame
python3 setup.py build
sudo python3 setup.py install

Module PySide

Vous pouvez utiliser le module PySide comme alternative à PyQt avec lequel il est compatible.

# actualise les dépôts apt-get
sudo apt-get update 
# récupère pyside
sudo apt-get install python3-pyside

Module PyQt

Revenez ici de temps en temps !

Module GPIO

Notez que les programmes qui accèdent aux GPIO par l'intermédiaire de ce module doivent être lancés en tant qu'administrateur.

wget http://pypi.python.org/packages/source/R/RPi.GPIO/RPi.GPIO-0.4.1a.tar.gz
tar xvfz RPi.GPIO-0.4.1a.tar.gz
cd RPi.GPIO-0.4.1a
sudo python3 setup.py install
cd ~