Rev. C boards from Element14

Jump to: navigation, search

First, thanks for this incredibly useful tool - I use it all the time! I recently got some Rev. C boards from Element14 and the tool stopped working. It appears to be a change in the U-Boot.img on the EMMC. If you are having this problem and save-emmc isn't loading automatically when you insert the SD card you may be able to work around it by mounting the card and creating a directory called 'dtbs' and copying the file named am335x-boneblack.dtb into that directory.

More detail can be found here: http://www.element14.com/community/message/136214/l/re-bbb-s2-user-boot-button-not-working-on-element14-board

I learned a lot about this process here: https://www.marshut.net/irqnmm/changing-bbb-boot-default-from-emmc-to-usd.html

15:53, 31 December 2014

Interesting, I just got the Element 14 Rev C board and didn't see this problem. I did have to use the barrel jack though, and had the other issues I mentioned.

16:27, 31 December 2014

I think in this case you are using the S2 button to boot completely off the SD card and thereby getting a consistent U-Boot image. I'm just sticking the card in an powering up the board, which relies on the U-Boot image loaded on the eMMC. There's not a strong reason to do that except that booting without S2 is simpler and does not require using the barrel jack.

13:57, 2 January 2015

You do not have permission to edit this page, for the following reasons:

  • The action you have requested is limited to users in the group: Users.
  • You must confirm your email address before editing pages. Please set and validate your email address through your user preferences.

You can view and copy the source of this page.

Return to Thread:Talk:BeagleBone Black Extracting eMMC contents/Rev. C boards from Element14/reply (3).