Thread history

From Talk:R-Car/Boards/Kingfisher
Viewing a history listing
Jump to: navigation, search
Time User Activity Comment
07:02, 9 April 2020 Khuber (talk | contribs)

New reply created

(Reply to Yocto Image for H3ULCB+Kingfisher M04)
23:55, 7 April 2020 Y.H. (talk | contribs)

New reply created

(Reply to Yocto Image for H3ULCB+Kingfisher M04)
00:21, 7 April 2020 Khuber (talk | contribs)

New reply created

(Reply to Yocto Image for H3ULCB+Kingfisher M04)
20:51, 5 April 2020 Y.H. (talk | contribs)

New reply created

(Reply to Yocto Image for H3ULCB+Kingfisher M04)
05:30, 3 April 2020 Khuber (talk | contribs)

New reply created

(Reply to Yocto Image for H3ULCB+Kingfisher M04)
22:26, 1 April 2020 Y.H. (talk | contribs)

New reply created

(Reply to Yocto Image for H3ULCB+Kingfisher M04)
06:44, 30 March 2020 Khuber (talk | contribs)

New reply created

(Reply to Yocto Image for H3ULCB+Kingfisher M04)
02:18, 27 March 2020 Y.H. (talk | contribs)

New reply created

(Reply to Yocto Image for H3ULCB+Kingfisher M04)
00:59, 27 March 2020 Khuber (talk | contribs)

Comment text edited

 
00:59, 27 March 2020 Khuber (talk | contribs)

New reply created

(Reply to Yocto Image for H3ULCB+Kingfisher M04)
00:01, 27 March 2020 Y.H. (talk | contribs)

New reply created

(Reply to Yocto Image for H3ULCB+Kingfisher M04)
06:05, 26 March 2020 Khuber (talk | contribs)

Comment text edited

 
06:03, 26 March 2020 Khuber (talk | contribs)

New thread created

 

What is the best way to create a Linux Yocto (preferably 3.21) for the H3ULCB+Kingfisher M04 configuration?


I tried the build instructions from here, but the image doesn't boot: https://elinux.org/R-Car/Boards/Kingfisher#Build_image

During the Kernel startup I get a panic:

[ 1.531217] loop: module loaded

[ 1.537959] renesas-rpc ee200000.rpc0: using DMA read (dma0chan0)

[ 1.544521] Bad mode in Error handler detected on CPU1, code 0xbf000000 -- SError

[ 1.552007] Internal error: Oops - bad mode: 0 [#1] PREEMPT SMP


Full details here: http://renesasrulz.com/adas/f/adas---forum-1845141225/15725/boot-failure-on-renesas-h3ulcb-kingfisher-board-based-on-r8a7795-es2-0/51386#51386


How can I build a Image which supports the Kingfisher features (especially 8ch. audio and USB3.0): https://elinux.org/R-Car/Boards/Kingfisher#S.2FW_support_status

06:03, 26 March 2020

Hello,


I confirmed that Yocto v3.21.0 is booted on H3ULCB(ES2.0 8GB) + KF(M04).

I checked your boot log, and noticed IPL and U-boot is old.

So, please update IPL and U-boot, then try to boot again.


Best regards.

00:01, 27 March 2020

Thanks for your help!

I have to admit that the boot log from the link above is not mine (just the error was the same).

My u-boot and IPL is newer, here is my full log of the kernel Oops: https://pastebin.com/wiXmDzxz

It is a dual-boot system which can also boot Android (for development), so the bootloader is from the Android build. I hope that's not the problem?

Here is my u-boot environment: https://pastebin.com/qqw8cJJS

00:59, 27 March 2020

Sorry, I have never used android on H3ULCB + KF.

But, I tested Yocto v3.21.0 on H3ULCB(ES2.0 4GB) + KF(M04) again.

And I confirmed that it works.


How about using yocto bootloader ?

if yocto can be booted, android bootloder may not be good for yocto...


Best regards.

02:18, 27 March 2020

Thanks for your help Y.H. With the Yocto-Firmware it boots as expected.

How I need to get the Android part working again, but boota is not supported in the Yocto's u-boot. But that's a different story now.

06:44, 30 March 2020

Hello,


I prepared android 9 for H3ULCB(ES2.0 4GB) + KF(M4), and tested for booting yocto.

In my environment, yocto was booted with android's IPL and U-boot.


If you use old version of android, how about updating it ?

22:26, 1 April 2020