Yocto Image for H3ULCB+Kingfisher M04

Jump to: navigation, search

Sorry, I have never used android on H3ULCB + KF.

But, I tested Yocto v3.21.0 on H3ULCB(ES2.0 4GB) + KF(M04) again.

And I confirmed that it works.


How about using yocto bootloader ?

if yocto can be booted, android bootloder may not be good for yocto...


Best regards.

03:18, 27 March 2020

Thanks for your help Y.H. With the Yocto-Firmware it boots as expected.

How I need to get the Android part working again, but boota is not supported in the Yocto's u-boot. But that's a different story now.

07:44, 30 March 2020

Hello,


I prepared android 9 for H3ULCB(ES2.0 4GB) + KF(M4), and tested for booting yocto.

In my environment, yocto was booted with android's IPL and U-boot.


If you use old version of android, how about updating it ?

23:26, 1 April 2020

Thank you, this is very valuable feedback! I also used Android 9 with the same hardware as you have but for me it didn't work.


Would you mind posting the output of the full boot process including the u-boot environment varibles?

06:30, 3 April 2020

Hello,


Here is my bootlog:

File:H3ulcb yocto with android ipl.txt


IPL is Rev.2.0.4 in my environment, but Rev.2.0.3 is used in your environment.

So, please update Android and IPL, then try to boot yocto v3.21.0 again.

21:51, 5 April 2020

Thank you very much for the boot-log of your system. I tried your suggestions with the new IPL and I'm now on the same version as you are.

Comparing the two logs (https://elinux.org/File:H3ulcb_yocto_with_android_ipl_kh.txt) they look very similar - except some memory addresses during IPL which I don't understand why they are different. Even the Kernel Size is identical - but the device tree is not.

$ md5sum *

1a2e4e2c0533dc557ead0a3a3e1dc9ae Image

dee81bd50b151322d5aa22d4d9af8747 Image-r8a7795-h3ulcb-kf.dtb

$ ls -l

-rw-r--r-- 1 root root 16497152 Apr 7 09:53 Image

-rw-r--r-- 1 root root 92809 Apr 7 09:53 Image-r8a7795-h3ulcb-kf.dtb


I did a recompile of my yocto to rule out any problems there. Also there are no local modifications done.

If you still have the files, would you mind uploading your Image.dtb (if it really differs) and also your srec files? This way I would be able to rule out some hardware issue on my side.

01:21, 7 April 2020

You do not have permission to edit this page, for the following reasons:

  • The action you have requested is limited to users in the group: Users.
  • You must confirm your email address before editing pages. Please set and validate your email address through your user preferences.

You can view and copy the source of this page.

Return to Thread:Talk:R-Car/Boards/Kingfisher/Yocto Image for H3ULCB+Kingfisher M04/reply (9).

Thank you Y.H., you are my hero!

I disabled RPC by adding DISABLE_RPC_ACCESS = "1" to my local.conf.

08:02, 9 April 2020