Can't Modify U-Boot Environment Variables on Updated Firmware

Jump to: navigation, search

Yes. One thing that wasn't clear to me was where to actually get those files. I've been using the ones that are found in ~/tmp/deploy/images/h3ulcb/ after building yocto. Assuming that's the correct path, I'm going to try rebuilding yocto in case I messed something up in that process.

One possible indication of what the issue is: I looked through the Renesas Device Manual https://www.renesas.com/en-us/doc/products/rcar/R-Car_StarterKit_Gen3_H3_M3_DEV_Rev.053.pdf to find a solution and found that in the section on booting the addresses the board boots from are slightly different from those on the e-linux wiki (looking at page 238 in particular). I'm a machine learning guy by trade and my architecture knowledge is rather scant comparatively so maybe this is nothing/not what I thought it means.

00:10, 19 July 2017

You do not have permission to edit this page, for the following reasons:

  • The action you have requested is limited to users in the group: Users.
  • You must confirm your email address before editing pages. Please set and validate your email address through your user preferences.

You can view and copy the source of this page.

Return to Thread:Talk:R-Car/Boards/Yocto-Gen3/Can't Modify U-Boot Environment Variables on Updated Firmware/reply (6).

Rebuilding the whole thing from scratch worked. Something must have gone wrong in the initial build because the .dtb file sizes between the two builds were off by a few hundred bytes.

23:38, 22 July 2017