I2C errors appeared with multiple usb devices

Jump to: navigation, search

As a result of our confirmation again, it can be reproduced, even if the USB device is not connected. Let me share the reproduction the scenario below. In addition, I used another board butI2C error is still reproduced.

[ Reproduce environment ] - Renesas bsp 3.15 - Rcar M3 StarterKit + KF-M06 - CMOS Camera OV5642

 https://
    www.aliexpress.com/item/OV5642-5-Million-High-Sensitivity-Camera-Module-Image-Sensor-Module-Manual-Fine-tuning-with-JPEG-Interface/32909308847.html
 Connected CMOS Camera to CN 29 on KF-M06.

- capture command

 Customized based on V4L2 video capture example in here.
 https://
    linuxtv.org/downloads/v4l-dvb-apis-new/uapi/v4l/capture.c.html
 please see the attached file.
 
 # capture -d /dev/video0 -F -f rgb32 -L 0 -T 0 -W 12800 -H 720 -c 1000 -t 60 -z

[pattern1] [ 1491.549362] i2c-rcar e66d8000.i2c: error -11 : f

[pattern2] [ 1443.614690] i2c-rcar e66d8000.i2c: error -110 : 3

When capture command was executed, I2C bus error occurs probability as below. pattern1: 3/10. pattern2: 4/10.

Your feedback would be welcome. Thanks

06:07, 1 April 2019

I confirmed but did not reproduce.(0/20)

root@m3ulcb:~# dmesg|grep ov5642
[    2.583901] ov5642 22-003c: Chip ID 0x5642 detected
root@m3ulcb:~# capture -d /dev/video0 -F -f rgb32 -L 0 -T 0 -W 1280 -H 720 -c 1000 -t 60 -z
fb0 Fixed Info:
     @ 0x57400000, len=8294400, line=7680 bytes,
   Geometry - 1280 x 800, 32 bpp
/dev/video0 FPS:  29.1
(snip)
/dev/video0 FPS:  29.1
root@m3ulcb:~#

My environments:
- M3 SK (Connected: HDMI, Serial(cn12), Ether(cn7))
- KF M06(Connected: CMOS camera(cn29))

03:09, 2 April 2019

Thank you for the confirmation. Let me re-check with another camera module.

04:01, 11 April 2019